TDX is down
Incident Report for MSU Denver ITS
Resolved
The TDX team has resolved the issue. The client portal is back online.
Posted Sep 22, 2022 - 14:39 MDT
Investigating
The TDX team has reported that TDX is down. The client portal and the status page are currently not responsive. The TDX team is aware of this and is working to get it back online.
Posted Sep 22, 2022 - 14:26 MDT