DegreeWorks maintenance
Incident Report for MSU Denver ITS
Resolved
DegreeWorks update and maintenance work was completed as anticipated. All services are fully functional. Thank you for your patience during this disruption.
Posted Dec 15, 2017 - 15:08 MST
Monitoring
ITS scheduled maintenance on 14-15 December

Information Technology Services (ITS) will perform maintenance on DegreeWorks and will not be available during the maintenance period. If you have any questions or concerns, please contact the ITS Helpdesk at 303-352-7548 or support.msudenver.edu.
Posted Dec 14, 2017 - 13:26 MST