Canvas Unavailable

Incident Report for MSU Denver ITS

Resolved

This issue is resolved. Please reference https://www.msudenver.edu/information-security-updates/ for further information on the incident.
Posted May 08, 2026 - 09:55 MDT

Investigating

Canvas is currently unavailable due to a malicious cyber-attack. ITS is aware of the situation and investigating solutions. Please avoid attempting to access Canvas for the time being.

More information will be provided as it becomes available.
Posted May 07, 2026 - 14:34 MDT
This incident affected: Canvas.