Company Portal Degradation

Incident Report for MSU Denver ITS

Resolved

This incident has been resolved.
Posted Apr 09, 2026 - 12:02 MDT

Update

We are continuing to investigate this issue.
Posted Apr 09, 2026 - 10:51 MDT

Investigating

Microsoft is currently investigating an issue affecting Company Portal downloads. ITS has confirmed that software downloaded through Company Portal may fail to install on Windows devices. ITS will provide updates as more information becomes available.
Posted Apr 07, 2026 - 08:25 MDT
This incident affected: Company Portal.