Multiple Reports of Phishing Email
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted Feb 12, 2023 - 10:13 MST
Update
The message deletion process remains underway, with an estimated completion time of 1:00AM MST.

As always, please refrain from clicking on links or opening attachments from unknown senders, and forward any suspicious messages to spam@msudenver.edu.
Posted Feb 11, 2023 - 23:44 MST
Monitoring
Multiple individuals received a message titled "Pet Sitter Job Available", and have reported it as Spam. ITS technicians are working to remove this message from all MSU Denver mailboxes, are blocking the link destination, and have contacted the handful of individuals who engaged with the sender.

As always, please refrain from clicking on links or opening attachments from unknown senders, and forward any suspicious messages to spam@msudenver.edu.
Posted Feb 11, 2023 - 21:23 MST
This incident affected: Information Security.